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Welcome to 
International
Space Station
Watch the Station Live

International Space Station allows to watch the International Space Station position 
over a zoomable map or 3d interactive word representation

The position is calculated by the application itself using orbit parameters that define 
from a mathematical point of view any object on a stable orbit around a planet

The position is calculated. It is NOT obtained via internet.

Calculation of the position is very very accurate, made in real time using the latest 
NASA algorithms to calculate it.

The application doesn’t requires a connection to know the position of the Space 
Station. 
It requires, for calculation, an internet connection for few seconds a day to update 
the orbital parameters (few KB of parametric  TLE data downloaded to give the 
application a range of 10 days of correct working without further orbital parameters 
update)
The only thing that makes the internet connection necessary is the map data used 
to represent the earth.
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If you are interested you can also get the iPhone / iPad  version named ‘ISS Track 2’ 
on iTunes.
Search on iTuns for ‘ISS Track 2’ for it.
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Getting Started
Easy of use

When you launch International Space Station it shows an a zoomable map the 
current position of the International Space Station 

It is calculated based on the current time. The calculation does not require an 
external connection (except to update orbital parameters data that usually changes 
once per day and are cached usually for 15 days in advance.

The zoomable maps is obtained from AppleMap servers and it does require a 
connection to be displayed.
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Reference
International Space Station shows the position of the International Space Station, 
orbiting the earth, inside a zoomable map

The data you see displayed are the current and precise one.
You can use this software to predict when the space Station will pass over your 
zone to watch the space station in the sky (at particular time of the day) naked eye.

We personally did it many times and it always worked and well, the Station in the 
sky, in the first hours of the night (after sunset) is indeed a spectacle, a lot more 
bigger then a start and moving really fast in the sky

International Space Station Position

The International Space Station is orbiting at around 400 Km (218 NM)  over the 
earth surface
It moves at around 27.500 Km/h , 17.000 MPH
This speed allows to make a complete orbit of the earth in around 1 and half hour

This application calc the actual position projection of the space station over a earth 
map.
In addition to the exact calculation of the ISS the app displays also current velocity 
and altitude and the predicted exact path of the next orbits.

From our test, comparing the data provided by our software with other sources, the 
returned result are precise. You can trust our application and the provided data.

You can select from the preferences to use the format and measure units you like 
for longitude, latitude, altitude and speed.

You can zoom in or zoom out the map using the embedded controllers inside the 
map or using the mouse wheel.
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A double click zoom in inside the map and option-double click zooms out.
Also using the mouse wheel you can zoom in or out, just rotating it over the map 
view.

You can select how much orbits to show in advance on the map, to see future 
position of the station up to the next 12 hours. From a popup in the toolbar or from 
the menu

You can watch the places the ISS pass over also at a very high zoom level

The circle around the ISS indicates the area where it is possible to see the ISS in 
the sky.

You can choose from the toolbar to have the station always positioned at the center 
of the map.
As the station moves the map scrolls to keep it centered.

Predicting the position of the Space Station

You can show the future paths of the station and see if it will pass over your zone
It can predict up to 12 hours of orbits

You can control the prediction length from the ‘Time’ popup in the menu bar or from 
the menu
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Naked eye observation of the Space Station

The ISS is larger then 100 meters (330 feet) and at the start and the of the night  
when you are in the dark and the station is exposed to the sun (it is 400 Km, 225 
NM over you) you can see it as a bright star (a bit more then a bright star) in the sky 
without using any optical instruments.
It is indeed a true spectacle, more brighter then a star and running fast in the sky, it 
takes few minutes to cover the sky from one side to the other if it is near your 
vertical on the passage (the visibility circle option in the application can help you in 
that).

If you see the path of the station near your position and the passage happens a bit 
after the  sunset for around an interval of 3 hours or before the dawn (for an interval 
of around 3 hours) you can see it at naked eye.

The point is: you need dark sky but the station over you still need to grab sun light
So during the day you have a sky that does not permit it and in the middle of the 
night the station will not get any sun light

This is the reason the right period is when it’s dark from 1/3 hours OR the sun is 
going to rise (1/3 hours before)

I watch it mainly in the summer and I and others were able to spot it from 21 (9 PM) 
with still sky not so dark till midnight with very dark sky but station starting to don’t 
get anymore sun light
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Time depends a lot of your altitude and relative longitude inside your time zone.

As you can imagine, as an example in Europe,  Italy and Spain have the same time 
zone but really a different longitude, so time applies in a different way, Spain is a lot 
more to west, so all will be shifted  1 hour or more relative to time clock , what really 
matters is position of sun and weather in your zone, not what the clock says.
So if in Italy right time during the summer can be from 21 (9 PM) in Spain will be 
from 22 (10 Pm). It depends of position (longitude) of your place in your time zone

The best track is the one that happens exactly near you , in any case, if you are 
inside the visibility circle around the station you can see the station passing over you 
(in the right time of the day when visibility conditions are the right one).

I had the opportunity to see them many times. It is always a nice view especially to 
watch with others.

If the station passes over you during the day you can’t see it, because it’s sunny, so 
it will not be a ‘valid’ passage.
If the station passes over you in the deep night still you can’t see it because it is not 
exposed to the sun and it doesn’t reflect any light, still not a ‘valid’ passage to see it.

So again, the right time is after the sunset when you are in the dark and it is getting 
the last sun rays or before the sunset when you are still in the dark but the station 
gets already the first sun rays.

You often get two at the price of one!
You can have 2 valid passages inside a 90 minutes interval, it can happen often 
because trajectory are not random, they are shifted form a distance that allows often 
to have 2 consecutive passages in your visibility circle, if the first is not a lot after 
sunset also the successive (after around 90 minutes)  is still at valid light condition.

Look at this pic:
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Here there are even 3 (and when I took the shot the station is entering visible circle 
from my current position) but the point is they have to be at the right time (light 
condition) so usually the third is not a good one, but 2 yes it happens often inside a 
night, before midnight.

Using different views

International Space Station 2 can use all the different views provided by AppleMap.
5 different views till macOS 10.12 and 6 views from macOS 10.13 (Apple added an 
additional one in AppleMap starting from macOS 10.13 High Sierra and successive

Plain View:

Plain View in dark Mode

Or plain View in Light mode
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It offers a plain map but with less details focusing more on traejectories.
(available only from macOs 10.13 High Sierra and successive)

Standard View

The more common used in AppleMap

Satellite
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Offers a view as seen from satellite

Hybrid

Satellite + map data

Satellite 3D
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A 3D interactive representation of the world with trajectories
Really wonderful to see
(If you soon out enough day and night difference is visualized)

As you see in the picture is morning in Europe and still night in the USA.

Hybrid 3D

3D satellite visualization + map data

International Space Station User Guide  © 2011-2022 Ecleti - Roberto Panetta page 12



Various Commands

You can reach the space station position pressing ‘Go to ISS’ in the toolbar
It immediately goes in the world where the space station is over

You can also draw a visibility circle around the station to see from where it is visible 
now

You can also show where you are (if you allowed the application to access your 
position)
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And I can draw a visibility circle around myself to know if next trajectories intersect
They do, but it’s morning here so it’s not the right time to see it naked eye
If it was in the evening it would be perfect.

You can also ask the application to follow the station in it’s movement

Don’t use a too much zoomed view in it or it has not a lot of sense making the map 
scrolling to follow an object running at 27 000 Km/h with a low scale representation 
(High zoom)
AppleMap simply will not do it or it will try without good results.
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Visibility Circle

Take the visibility circle zone with a grain of salt
The true radius of the visibility circle depends a lot of various circumstance, light 
condition, weather, your altitude and geographic situation around you (sea, 
mountains)
You can have different results (a larger or a smaller radius from your positions)
If you accumulate experience you will be able to ‘know’ at what distance you can 
start to see the station depending of conditions and where you are

Another thing is: catching it when ‘it’s coming’ is not easy even if watching the map 
live you know from where it’s coming (without it’s almost impossible because you 
don’t know from where and when)

Following the station when ‘it’s going’ , exiting from your visibility circle is more easy, 
your eye can follow it really till the end and it’s really nice watching the map to see 
till where you still can see it … and you will be impressed if you have good visibility 
condition, of how far you can see it (often more then the visibility circle)

So the point is the visibility circle is just an ‘indication’ to help you.

Position Calculation by the Application

Calculation is realised by the application using the last advanced algorithm in C and 
C++ that we adapted to Mac also creating some special Cocoa / Objective-C class 
for satellite algorithms management and orbital data update.

The position is NOT get from internet. To made this little toy we used the same 
algorithms NASA uses for orbital calculation, so it’s not a toy at all…

To correctly work the application requires 2 things:

• A clock set correctly
• An internet connection

Your computer Clock

To obtain an exact ISS position calculation your computer clock needs to be correct, 

this should be alway true if you have the ‘Set date and time automatically’  checked 
in your preferences.

If computer clock is not correct, calculation is wrong.
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Another thing necessary to obtain the correct calculation is to use the right orbital 
data in the calculation, the app updates daily from our server the orbital data to 
ensure you have always the correct orbital data in use.
Our server automatically updates the orbital data from NASA, in this way your app, 
that takes the data from our server in a proper standard format, has always the 
orbital data to use for a correct calculation.
In a word to ensure your orbital data is correct you have to do ... nothing... just 
launch the app and ensure you have a working internet connection.

The app knows when to contact our server to update the orbital data and knows 
when to use the next orbital data in the list. The app contact our server max once 
per day to avoid bandwidth waste, it usually obtain in background via internet from 
our server the orbital data for the next 7/15 days, ready to be used when necessary.

You can see which orbital data is in use for calculation, reading it in the upper part of 
the window the data specific.
You can see the app will change any day the Orbital data in use
As example as in the figure:
Sat is always 25444 which is the ISS satellite code
and as example EPOCH 18181.51092619
the first two number are the last two of the year (18 means 2018) the following 3 
numbers are the day of the year 181 in the example means June 30
and the fractional part .51092619 means the fractional part of the day (24 hours) of 
validity when to start to use this orbital data (time of day is in UTC, not your local 
time, we are dealing on something in the space and we have to use a universal 
time, not something depending of your position)

As you see the application downloaded form our server parameters valid for a 
perfect calculation till 13 July 2018, so for the next 14 days of the time the pict was 
taken (it was early morning July 1 in Europe )

For reference we report both your local time and the UTC time at the bottom of the 
window

Connection ON required

A connection to the internet is required for 2 reasons:
1) Update the orbital data from our server. It is done daily but data are cached for 

the next days (15 days) . Our server get it daily from NASA and adjust them to 
the right format. Data transferred are minimal, few KB per day

2) Display the map via AppleMap servers (That requires a connection all the time) 
and this requires really more data transfer
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TLE Window

The TLE window allow to see the updated parametric data the application 
downloads (usually once per day) for calculation of the correct orbit

International Space Station Cam window

The application provides a link to the International Space Station cam, installed 
onboard

You can open it under the Window > Open in Browser > Station Web Cam menu.

The cam window will automatically connect to the stream coming from the 
International Space Station

Note that this Cam takes usually some time to connect too. Be patient and 
sometime, if it doesn’t work, retry. It works, it just requires some time to start.

Sometime you get direct streaming from the station, sometime images from ground 
from NASA, try many times and you will be lucky.

Some time a watch of the panel at NASA showing the Space Station position.

Sometime you can see the cam on the Space Station pointing to the earth
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When you watch at the cam pointing to the earth, consider that often it is not pointed 
to the vertical, so it can show point back on the track or forward or on the left or on 
the right, at 350 Km of altitude they have a very large view field!

Other Links Provided

Under Window > Open in Browser the application provides in addition to the Station 
web cam other links:

Station page at Nasa
Station (Facebook)
Station (Youtube)
Station (Tweeter)
Nasa HQ Photo

Dark Appearance Mode

This application is fully compatible with Dark Appearance Mode available on macOS 
from macOS 10.14 Mojave and obviously with Light Appearance Mode on any 
macOS release it can run on.

Preferences

General

General preferences allows you to change the coordinate format and the measure 
units to display altitude and and speed

You can also select to have ‘Keep Centered’ at startup or not.
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Help

International Space Station provides a PDF guides under the Help Menu.
 

Support
 
You can also obtain support using the ‘Email Support command. An email will be 
prepared using your email client with the correct address to send to.
Yes, we answer to your emails.

About Tension Software and Ecleti

All the software asset by Tension Software is now under Ecleti 
New company name but still the same owner and main developer (Roberto Panetta)
So for the users nothing changes. We provide the same software and the services. 
All the user licenses are valid and assistance is provided as before to all our users.

Credits
NASA  - National Aeronautics & Space Administration 
© OpenStreetMap contributors, CC-BY-SA
NOVAS U.S. Naval Observatory
David A. Vallado
Paul Crawford
Richard Hujsak
T. S. Kelso
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