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Welcome to NoteList
NoteList to store data in a free format

NoteList allows you to store data in a free format using text and images with full 
word processing capabilities.
NoteList is document based app and can manage and unlimited number of 
documents and any document can store an unlimited number of notes.
A note can be a full text in TXT format or an RTF text with also images embedded.

NoteList is based on a very simple interface with the list of notes on the left and the 
content of the selected note full expanded on the right.

Notes can be searched for name and content and category and sorted for name, 
category, creation date, modification date and editable flag.

Any note can be assigned a category. Categories, thanks to color label, add a new 
dimension on how the user can organize notes.
Notelist is 100% Lite Mode and Dark Mode complaint, when you change mode it will 
immediately change the document background color to adapt to your choice.
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Getting Started with NoteList
Working with NoteList is simple and intuitive

Any NoteList document has the window divided in two parts: the left pane and the 
right pane.

All the notes inside in the document are listed in the left pane.
Clicking on in the left pane on a note will make it the selected note.
The selected note in the left pane shows its content on the right pane.
You can select one note per time.
The right pane displays always the content of the note selected in the left pane.
When you create a new document in NoteList it is created with a new note inserted.

Create a Note

To create a note click in the Add Note button in the toolbar or select ‘Add Note’ 
under the Edit menu
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The created note will be selected and it will appear in a new row in the left pane list 
already selected
The content of the note is on the right. A new note is created with an empty content

Edit a note

To edit a note select it in the left pane showing the list of the note inside the 
document
Click on the right and start editing the note as in a normal document
You can apply formatting and insert  pictures.
If the note is write protected you need to click on the pencil icon to unlock it

It is possible to create full rtf text with images and using a ruler to format the note

Use categories

Press the category button in the toolbar or select ‘Edit categories’ from the ‘Edit’ 
menu.
The category panel will open.
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Create a new category and assign a new name to it
Assign a color to the text and a color to the label using the Color Well Control and 
close the category panel.
Now back in the main window if you press the 'Category' popup in the right panel 
you can assign a category to the selected note choosing from the available.

Assign to the note a category

In the table list the notes will display the label of the category assigned using the 
colors of the category for the label.
Select from the popup menu the category to assign to a note
Using colors for the category label helps differentiate from different notes
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Filter notes

Now you can filter the notes inside the document selecting from the "Show 
Category" popup in the toolbar a category.
In the document will be filtered out all categories but the selected category.

You can further restrict your filtering inserting in the "Find in All Notes" search field in 
the toolbar a string

NoteList User Guide - © 2005-2024 Ecleti - Roberto Panetta page 6



Text features

Notes are editable as RTF text inserting different font, styles, size and pictures.
Inside any single note text can be searched and spell-checked.
Also "Check Spelling as You Type" can be enabled form the "Edit" menu.
You can also sort the notes by title and by category clicking in the head of the left 
panel.

Done

In few seconds you just learned how to use NoteList.
Using categories with color labels and a titles you can use hundred of text notes 
containing all the frequented text notes you use in your work and at your home.
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NoteList Reference

Creating a new note

To create a new note select the 'Add Note' button on the toolbar or the command 
'Add Note' from the menu.

The new note will be created with the standard name "Untitled Note" and appended 
at the end of the list.

You can also use the bottom toolbar at the foot of the list of the notes.

Another way to create a note:
Using the ‘Add Note from File’ command from the Tool menu.
You can select a txt, rtf or rtfd file from the finder via a Open file panel, a note with 
the content of the selected file will be added to the list of the note in the current 
document.
The note is created with the same category of the previous selected note

Another way is to drop a text or rtf or rtfd (rtf with images) from the finder to the list 
of the notes
A new notes with the dropped content will be added, the note will have the title 
equals to the dropped file name

Note that the file needs to be dropped on the list (on the left pane)
If you drop a file on a note content (on the right pane) you just add the icon of the 
dropped document to the current note

If you drag and drop a text to the current note, the text will be added as usually 
supported by text editors.

Changing the note title

The note title can be edited inside the title field after selecting the note in the list 
table on the left of the window.
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You can also double click the title of the note directly in the list of the notes to edit 
it’s title

Changing the note category

The note category can be changed selecting a category in the category popup in the 
right pane. The popup will show all the categories available.
After assigning a category to a note the list table update immediately the category 
associated to the note with the right name and color combination of the label.

Changing the characteristic of the category assigned to the note will change 
instantly the note and all the notes with this category assigned. 
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Deleting a note

To delete a note you have 3 ways:

• Select ‘Delete Note’ under the ‘Edit’ menu
• Press the ‘Delete’ button in the toolbar 
 

 

• Press the ‘-’ button at the foot of the list of the note  
 

 

Both will display a dialog asking you to confirm to delete the note

The action can be undone.

Copy a note

Often NoteList is used to store text to be used in other software by copy and paste
You can copy the entire content of a single note selecting one of the two toolbar 
button to copy the note in clipboard
‘Copy Text’ will copy the content of the note as TEXT
‘Copy RTFD’ will copy the note as full formatted text + images inside

The copy TXT and Copy RTF are not in the default toolbar
You need to add them in the toolbar right-clicking in the toolbar and selecting 
‘Customize Toolbar…’
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Then drag on the toolbar the icons you need to use.

Duplicate a note

Do duplicate a note select ‘Duplicate Note’ form the ‘Edit’ menu
The note will be duplicated appending ‘copy’ to its name
The creation date and the modification date will be update to the current one

Editing available categories 

To edit the available categories open the categories sheet using the 'Category' 
command under the 'Edit' menu or the command in the toolbar.
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When in the Category sheet you can add, delete and edit categories. 
The category panel shows near each category how many notes in the document 
use it.
You can edit the name of a category, the label background color and the text color.
Editing a category changes any note using the edited category instantly.
When a category is assigned to a note, the note is dynamically linked to the 
category. 
Changing the category characteristic will change all the notes assigned to that 
category when you select the new characteristic.
When a category is used at least in one note it is not possible to delete the category.
If you want to delete a category you have to delete the associated notes or change 
the category assigned to them.

Editing the body of a note

Selecting the body of the note you can edit it. The body of a note is an RTF 
document where you can put form simply short text only note to a complex 
document with formatted text and pictures.

Text can be edited using various font and adding pictures using drag and drop or 
copy and paste

A ruler can be used to format text as the user likes.
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Making a note not editable

To make a note non editable click on the ‘Edit/View’ Button
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To make it editable again re-click on the ‘Edit/View’ button
You can use also the ‘Allow Editing / Prevent Editing’ command under the ‘Text’ 
menu

Changing text format

Using the "Format" menu and the "Font" panel the text inside any single note can be 
formatted as requested in a standard and intuitive Mac way.
If you know how to use the standard "Text edit" application by Apple, you know how 
to edit a note inside NoteList.

Using the ruler

You can use a ruler allowing you to format any single paragraph of your note in a 
different way.
Ruler can be enabled from the icon in the upper part of the note area

Ruler can be enabled from the icon in the upper part of the note are
When moving on a note with Editing disabled the ruler is automatically disabled but 
a dot under the icon informs you it’s still enabled on allowed notes, switching to an 
editable note will show the rule

Making a note all plain text

To make a note all plain text select ‘Make All Plain text’ from the ‘Text’ menu

NoteList User Guide - © 2005-2024 Ecleti - Roberto Panetta page 14



Confirm the dialog to make the note in plain text format

Check spelling 

You can check spell the text inside a note using the "Spelling" submenu under the 
"Edit" menu.

Deleting a note

To delete a note select it in the list on the left and select "Delete Note" from the Edit 
menu or from the toolbar or from the bottom bar in the list of the notes. 

or from the bottom bar in the list of the notes pressing the ‘-’ button. 

NoteList requires at least a note inside a document, if you delete the last remaining 
note in a document, NoteList will create a new empty one for you.

Browse the notes

To browse the notes, you can select the note in the list with the mouse or use the 
buttons in the toolbar or the command under the menu or the keyboard shortcuts. 
Look inside the ‘Edit’ menu to see the menu command to move through notes
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Sorting notes

You can sort notes clicking in the head of the left pane. You can sort notes by 
category, title, editable flag, creation date and modification date.
Clicking on the same head causes sort order to be reversed (ascending - 
descending).

You can also sort notes using the commands from the Tool menu.
The menu provides also keyboard shortcuts for sorting the notes
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When a document is closed and reopened next time  it will remember how it was 
sorted last time it was used sorting the document for you automatically. 

You can make sorting to adopt:

• Standard Case Sensitive
• Localized
• Localized Case Sensitive

You can change these settings from the preferences:

If you change this setting while a document is opened you see it change to adapt to 
the adopted sort method.
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Copy a note

You can copy inside a note in the standard way, the right panel is a standard editor 
and you can copy as usual form.
You can also copy all the content of a note (graphics included) using the copy button 
in the toolbar or the "Copy Note" command form the Edit menu
You can also copy all the content of a note as plaint text, using the "Copy Note as 
text Only" command. You have available command buttons in the toolbar for these 
commands. They are not in the default palette, so you need to customize the toolbar 
to have them available. 

Customizing a toolbar is a standard operation in any macOS application providing a 
standard toolbar, to customize it right-click or use the apposite icon button in the 
default palette in NoteList.

Change the editable flag for multiple notes in a click

You can change the edit flag for more then one notes in a single command
Select from the note list (holding the shift or the command key) more then one note
On the right will appear the option to change the edit flag in a single click

Multiple notes copied as a single text in a click

You can concatenate and copy more then one notes in a single command
Select from the note list (holding the shift or the command key) more then one note
On the right will appear the option to concatenate all the selected notes and copy 
them in the clipboard. 
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Click the button ‘Concat Selected Notes to Clipboard’

and all the note content will be copied in a single text inside the clipboard

Multiple notes save on disk as a single text in a click

You can concatenate and save on disk more then one notes in a single command
Select from the note list (holding the shift or the command key) more then one note
On the right will appear the option to save all the selected notes in a single text file 
on disk. 

Press the button and select a file to save to.

Delete multiple notes in a single click

You can delete more then one notes in a single command
Select from the note list (holding the shift or the command key) more then one note
On the right will appear the option to delete or the selected notes
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Drag and drop of text

It is possible to drag and drop a portion of text from and to the text of a selected 
note (on the right pane of the NoteList window) . NoteList will fully support it placing 
the text at the drop position.

Drag and drop of files

It is also possible to drag from the finder a file inside the list of the notes (on the left 
pane of the NoteList window) 
NoteList will create a new note containing the text inside the dropped file.
The note will have the name of the dropped file. 

Accepted file type are:
.txt (text file)
.rtf (rich text format file)
.rtfd (rich text format file with images embedded)

The new note will be created with the same category of the previous selected note

Filtering notes

You can filter the notes inside a document using the "Search Category" popup menu 
inside the toolbar. Selecting a category will filter and show only the notes with the 
selected category. 
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To show all the notes select "Show All" from the popup. 

Search for a note inside NoteList

To search for notes inside all the notes inside a NoteList document, insert in the find 
field “Search text" a text to search, NoteList will adapt the list to the searched text 
showing only matching notes as you type.

When a search is in place an info area opens immediately under the toolbar 
showing the result of the search

To go back to viewing all the available notes make empty the search string (you can 
click the x on the right of the search string to empty it)
To search inside a note use the commands under the "Find" menu. This commands 
are similar to the one you usually find in a standard word processor and they all 
apply to the current selected note.

Category filtering and searching combined.

Remember that when you can combine the search box and a category filtering. The 
search criteria will be the category AND the key inserted inside the "Find in All 
Notes" field in the toolbar.
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Search Inside the Notes

After searching among notes, to search inside a single note, NoteList automatically 
fills for you the local search panel.
Simply press Command-F and you will see the ‘local search fild’ will appear with all 
the available options

You can search with different options and use the field also to search and replaces 
occurrences.
When you press Command-F inside the note search field, the search keyword will 
be already filled with the current search string used in the toolbar and all the 
occurrences of the selected keyword will be halite inside the selected note.

Info on a note
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To obtain info on the selected note you can select the ‘Note Info’ command for the 
tool menu
The info on the Active note will be displayed in a HUD floating window
It will show the creation date and the modification date.
For documents created using a release previous of the 2.10, the creation and 
modification date will be set to the first opening of the document using release 2.10.

Saving a document

NoteList allows to save and reopen a document on disk as any standard document 
based Cocoa application.
It saves on disk also the dimension of the window and the width of the columns you 
set during the use of the document.
When you reopen a document you find it in the state you saved it

Light and Dark Appearance Mode

NoteList is fully compatible with Dark Appearance Mode available on macOS from 
macOS 10.14 Mojave and successive.
At any time you can switch from one mode to another and not only the interface but 
also the content will adapt to the new mode. You can see also the background of 
your notes will change from Light Mode  to Dark Mode and viceversa.

Preferences

To edit preferences use the "Preferences" command under the NoteList Menu.
NoteList uses a standard Preference Windows where you can customize many 
aspect of the application selecting inside the preferences windows the icon in the 
preference window toolbar.

General: 
Specify the action to do at startup
New Document create a new document at startup
File browser open the dialog to select a NoteList document from disk to launch 
None performs nothing at startup
Open Selected Document allows to select a document and have it launched 
automatically at startup, this is a standard way to operate in case you use just a 
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single document as the main repository of your notes or use often the same 
document.

At any successive relaunch NoteList will execute the option selected.
The additional two buttons at the foot of the edit field let you:
• Show in the finder the selected file
• Test open the selected file as it will be done at the next application launch

Edit:
Opening a Document

• Start with ruler (starts a document with ruler visible)
• Check Spelling as you type (starts a document with Check Spelling as you 

type enabled)

Creating a New Note
• The default font
• The default size 
• The default format
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Advanced
Enable File Autorecovery (to have the application maintain a parallel file to the one 
used for the document) In case of crash the file is used to recovery the lost data. It 
works saving automatically on the parallel file the data when your document needs 
it.
You can set up the delay between the moment the document become dirty (it needs 
saving) and when the data are saved on the recovery file. Do not use a too low 
interval to avoid a continue write access to the disk.
In case of crash the application uses automatically the auto recovery file at 
relaunch, no manual action required!

You can also enable autosave specifying a save interval time.
Using it any file will be saved automatically on disk after a specified delay. New 
document never saved on disk are excluded until you save it on disk assigning a 
name and a save location.
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Update

* Update section in the preferences is not available in the App Store Release 
(if you purchased via the App Store you don’t need it, to obtain an update 
use the App Store Update function) 

NoteList can inform you if an update is available.
If enabled, the application will check no more then once a day.
We suggest to keep it enabled.

When notified of an update available, if you download the upgrade, you need to 
manually install it.
A common error is to download an upgrade and install it maintaining the old 
application somewhere on the hard disk.
Then using to open the documents sometime the old application and sometime the 
new one. This cause some problems*.
 To avoid it simply install your application in the place dedicated to it, the Application 
folder. When you install an update on the standard Application folder, the system will 
ask if you want to replace the old one with the new, answering yes will install the 
new one replacing the old.

*If the application says the document you are trying to open was created with a newer 
version of the application, probably you have two different release of the application on your 
Hard Disk and you are trying to open a document with the older version after having 
modified the document with the new one. When you receive a similar message open the 
about box inside the application and see if you are running the last release. In case 
download it, install it and USE it!

Customizing the toolbar

To customize the toolbar right click with the mouse in the toolbar and select 
"Customize Toolbar…' This is a common command in almost all Macintosh 
applications
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Help

NoteList provides a PDF User Guide accessible under the Help menu.

 

Support
 
You can also obtain support using the ‘Support Email...’ command. An email will be 
prepared using your email client with the correct address to send to.
Yes, we answer to your emails.

NoteList is a commercial program

NoteList is available via the Apple App Store (fully enabled)
and via our site (in an unlicensed version)

In case of the App Store release, a license is already included with your App 
Store purchase and you don’t need to buy a license 

If download from our site or on the web elsewhere, you can use our software for a 
test period of 10 days
After that you are required to buy a license to fully enable it and be legally 
authorized to continue to use our software

Licensing NoteList
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In case of the App Store release a license is already included with your App 
Store purchase and you don’t need to buy a license 

If you are using a version download from websites, you can buy a license to use our 
software using the ‘Buy License’ command in the ‘License’ dialog.
You will open in your browser our license web page on our web site 
From there you can buy a license to use NoteList using one of the payment service 
we provide. It easy, fast, and secure and all most important form of payment are 
accepted.
We carefully selected or international reseller to be sure the buying experience for 
our customer will be as best as possible and without any problems.
After purchase you will receive from Ecleti a license email containing your full name 
and a license code
Open the License dialog with the command ‘license’ under the ‘NoteList’ menu and 
insert these data in the License dialog. The software will become fully licensed and 
fully enabled for future use.

Name and license code are remembered by the program and don’t need to be re-
inserted at successive launch.
In case you move on a new Mac you need to re-insert your name and license
The license is valid for a single Macintosh. You can purchase for two Mac as long as 
they are not used at the same time, as example a desktop and a laptop used by the 
same user.

About Tension Software and Ecleti

All the software asset by Tension Software is now under Ecleti 
New company name but still the same owner and main developer (Roberto Panetta)
So for the users nothing changes. We provide the same software and the services. 
All the user licenses purchased from Tension Software are still valid and assistance 
is provided as before to all our users.
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